Electrodragon Forum » Search » user:lboucher post:true

Problems with Energy Monitor Shield R2.1

After much testing, i finally realized that the issue is powering the Uno from my laptop USB.

I was relying on the Serial print to display the current.

I used an arduino shield to spit out UDP and wireshark to read the data.

Disconnected USB line and powered from a seperate supp

testing ems energy monitor uno lboucher •  2018-06-23 • Last reply from chao
6

Problems with Energy Monitor Shield R2.1

I went back and measured the heater i was using. Its pulling 7-8 amps...

To be double sure, i wrapped the AC line around the sensor 4X, so thats ~32 amps.


The IRMS value changed from ~.2 to .8 ish when I tried A1, but there is soo much noise the signal is totally usel

testing ems energy monitor uno lboucher •  2018-06-23 • Last reply from chao
6

Problems with Energy Monitor Shield R2.1

Also, i tried 2 completely different sets of hardware with the exact same results, so i must be missing something. Also, i don't have anything else hooked up. No screens or ethernet shield or SD card or anything. Just the EMS shield, Uno, Sensor, and VDC supply to the Uno power input, and USB to

testing ems energy monitor uno lboucher •  2018-06-22 • Last reply from chao
6

Problems with Energy Monitor Shield R2.1

Also, i tried 2 completely different sets of hardware with the exact same results, so i must be missing something. Also, i don't have anything else hooked up. No screens or ethernet shield or SD card or anything. Just the EMS shield, Uno, Sensor, and VDC supply to the Uno power input, and USB to

testing ems energy monitor uno lboucher •  2018-06-22 • Last reply from chao
6
Log in
Information Bar
Hello World! Reclamation land, waiting for the mining of tags.